WARNING: OnBoard RAID1 Does Not Work!

Please note that this post was migrated to my new blog platform. There may be bad formating, broken links, images, downloads and so on. If you need an item on this page, please contact me and I will do my best to get it from my backups.


For those of you running motherboards with SATA or IDE OnBoard RAID Controllers, you are all being fooled in thinking your data is safe.

Yesterday my machine started to become un-responsive when I was reading/writing a word document and an excel file.  It would freeze/hang for about 10s, and start working again.  This is a typical sign that something is wrong.  I rebooted and immediately Chkdsk wants to check my drive D.  I allow it, and it throws all sorts of index errors and inserts.  So much that it gets caught in an endless loop, never to exit.

I have an Asus P5AD2-E Premium mobo - the company's flagship product for a short time.  It has onboard SATA and IDE RAID.  Actually two different RAID controllers - Silicon Image (Hardware) and an Intel (Software) controller.  Each has 4 SATA ports.  I did not want to use the Software raid, so I elected to setup my arrays on the Hardware version.

I have two WD 36 GB 10,000rpm SATA Rapters in an RAID0 array for my OS drive (C).
I had two Maxtor 200GB 7,200rpm SATA drives in an RAID1 array for my Data drive (D).

Trying my best to get Windows to boot, I finally get into the OS with no "D" drive and start checking the Raid's driver logs and event logs.  Nothing.  Nothing but a bunch of NTFS write errors from the previous boot.  The raid drivers usually log to a log file in the C drive when there's an error - nothing is there.

I tried to connect one of the mirrored drives as a standard SATA drive on the Intel SATA ports (RAID is disabled on that part).  I found the drive, everything seemed to be there.  I connected the other mirrored drive.  It saw it, and everything seemed to be ok.

I thought I was in the clear, until I started accessing my documents.  Oh god!  The majority of them are 0 bytes.  In a panic, I went to check some of my oldest - most important files to me.  GONE.  They are not accessable.  I shut hte system down, connected the other mirror'd drive up in place of that HDD, booted and SAME EFFECT!  The majority of my files are 0 bytes, corrupted, or invalid formats.

And just for completion sake.  Yes, I tried the drives in another machine.  Yes, I used Scan disk to search for errors/fix them (no problems found).  Yes I used checkdsk /f /v on both disks and it did not find any errors.  The drives seem to work just fine.  And yes, the EXACT files are messed up on BOTH HDDs.


Asus' OnBoard RAID destroyed my files.  From all angles and checks, the drives seems to be working just fine.  I knew I should not have trusted a cheap OnBoard RAID solution.  I wish I still had my Promise SATA controller.


> Revision History
> About the author